Réaliser des sommes conditionnelles

Poster un message

Réaliser des sommes conditionnelles longues et variables

13 janvier 2010,

bonjour a tous je decouvre la fonction sommeprod mais je me heurte a un petit casse tete, j’ai un tableau de 2 colonne obtenu avec pilote de données colonne 1 des references colonne 2 des totaux

Album enfant 7608 Bande dessinée 1127 Bande dessinée enfant 5009 Biographie 638 conte enfant 488 Documentaire 211 Documentaire enfant 37 Documentaire jeune 16 Humour 58 Pas de GENRE 7107 Poésie 11 Poésie enfant 21 Poésie junior 18 Roman 8799 Roman enfant 2107 Roman jeune 941 Roman Policier 1053 Roman science fiction 105 Théâtre 31 Théâtre junior 3 Usuel 41

ensuite je dois definir des familles

Bande dessinée + Nouvelle + Roman + Roman Policier Roman science fiction correspond a la famille Fictions Adultes

je souhaite faire des totaux pour chaque famille avec sommeprod (a moins qu’il y ait plus simple !) je voudrais simplifier au maximum la saisie des sommeprod car je me retrouve avec des formules du genre =SOMMEPROD(C3:C15*((B3:B15=F4)+(B3:B15="Bande dessinée")+(B3:B15="Roman Policier")+(B3:B15="Roman Policier")).Je vais me retrouver avec des formule a rallonge et difficile a verifier, je prevois des familles plus importantes et tres variables. Auriez vous des idees a me proposer ? Merci d’avance

Titre du message

Texte du message

(Pour créer des paragraphes, laissez simplement des lignes vides.)

Captcha Anti-Spam

Lien hypertexte (optionnel)

(Si votre message se réfère à un article publié sur le Web, ou à une page fournissant plus d'informations, vous pouvez indiquer ci-après le titre de la page et son adresse.)

Qui êtes-vous ? (optionnel)

Merci de votre participation

Informations complémentaires

C'est-à-dire

Bien choisir son titre est très important en particulier lorsque vous lancez un nouveau message.

Les adresses emails apparaissent "cryptées". C'est un cryptage sommaire et un peu contraignant puisqu'il remplace l'arobase par trois caractères aléatoires, "open@office.org" devient "open h6Y office.org" mais c'est deja une bonne barrière contre le SPAM.

Merci de rester courtois, de garder un oeil sur l'orthographe et de ne pas abuser des majuscules et du langage SMS.

Informations générales

Juste une image

Blue Eyes Playing Blue Eyes Playing
Creative Commons BY-SA